Python 3.7 and PIP problem with SSL DEBIAN

On Debian stretch, installing libssl1.0-dev (and removing libssl-dev) with apt worked fine. Python installs fine now. Tested in Ubuntu 16.04/18.04 In Python-3.6.4/Modules/Setup uncomment the following lines: # SSL=/usr/local/ssl # _ssl _ssl.c \ # -DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \ # -L$(SSL)/lib -lssl -lcrypto Then recompile the package: $ sudo ./configure --enable-optimizations $ sudo make altinstall Installation Python 3.7 in source How to Install Python 3.6 on Ubuntu & LinuxMint
Read More